BLOOCK Docs
Search…
⌃K

Python SDK

This page has all the information needed to install and setup the BLOOCK's SDK for Python. If you are looking for documentation related to an specific functionality, please refer to it's specific section.

Requirements

To run the SDK for Python you will need:
  • Python version >= 3.7
  • PIP for installing the package
Please refer also to OS support for current operating system requirements

Installation

The Python SDK is available through PIP, to install it, you can run the following command:
PIP
pip install bloock==SDK_VERSION
To find the latest version available, you can visit the PyPI page for this library.

Set up

To start working with most of the functionalities of our SDKs, you will need an API Key. Please, follow the instructions of Create an API Key to get one.
Here's the code needed to properly configure the SDK Client with the API Key:
Python
import os
import bloock
bloock.api_key = os.getenv("API_KEY", default='apiKey')